Android development

Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8

Solved Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8
1kviews

Hello all in this Android solution, I will discuss a problem I’m currently experiencing in Android Studio. Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8. Today I downloaded and installed Android studio’s most recent version, but I’m getting an error message like this: Android Gradle plugin requires Java 11 to function. The current version of Java is Java 1.8 for Java. Therefore, I am going to explain to you the possible solutions to this issue. So, let’s begin this article to resolve this issue.

How did This Error Come into your project?

I just installed Android studio’s latest version but I am experiencing this error. The other problem because you’ve used the most up-to-date android libraries and plugins. Also, our project runs on an older version of SDK and plugins.

How To Solve Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8 Error?

If the JVM points to version 1.8 then you can change it from the android studio settings. You can click on File–>Setting–>Build, Execution, Deployment → Build Tools → Gradle → *Gradle JDK. And Apply then click on OK

Android Gradle plugin requires Java 11 to run

 

How To Fix Android Gradle issue? is a requirement for Java 11 to run. Currently working with Java 1.8 Problem?

For Finding the Android Gradle build plugin requires Java 11 to run. The Java currently your are using 1.8 Error If you find that the JVM indicates version 1.8 Then you must alter it in the settings.

  1. Youo can find it inside the Preferences. And Select Build Execution, Deployment -> Build Tools -> Gradle. And Choose Gradle JDK to 11. The other option you can Download Page. Install JDK ZIP file. JDK ZIP file on your system.
  2. (Let’s say Windows)Extract the file to any folder with permissions that are high in your PC’s main directory. Now, open it and go to your Android studio project structure in men File* – The project structure. Then paste the directory in which you extracted the JDK version to this page. As you can see my version is JDK 16 at present and is installed in the directory.

Solution 1: Android Gradle plugin requires Java 11 to run

  1. If the JVM is pointed to Gradle version 1.8 then you must modify it from the settings.
  2. It is located in the File ->  preferences.
  3. After that Select Build, Execution, Deployment.
  4. And  Build Tools.
  5. Then, Gradle.
  6. Select Gradle JDK to 11.
  7. The problem must be resolved.

Solution 2: Android Gradle plugin requires Java 11 to run

  1. Go to Download Page.
  2. Get JDK ZIP file. JDK ZIP file for your system. (Let’s say Windows)
  3. Extract it to any folder with permissions that are high in the main directory of your PC
  4. Then open and go to your Android Studio project structure. It is found in the Men File* — Structure of the project.
  5. Copy the directory from which you downloaded the JDK version of the software here. As you can see the version I have is JDK 16 at the moment and it is installed in that directory.

 

 

Read More Tutorial